Skip to main content

Posts

Showing posts with the label email

Cấu hình hệ thống email để không bị quẳng vào Spam

Mail spam và OpenDKIM Cài đặt và vận hành 1 hệ thống email là một trong những thứ lằng nhằng nhất khi làm sysadmin . Một hệ thống email hoàn chỉnh hoạt động sẽ cần đến khoảng một chục thành phần khác nhau, nhưng hoạt động là chưa đủ, để email gửi ngon lành, không bị vào Spam thì phải hiểu thêm một đống thứ nữa. Khi gửi mail đến Gmail, hệ thống Gmail sẽ coi mail của bạn là spam nếu email đó chưa authenticated. Xem đầy đủ tại đây: https://support.google.com/mail/answer/81126?hl=en#authentication Google yêu cầu hệ thống của bạn khi gửi mail phải - "Sign message" bằng DKIM - Phải có SPF DNS record tương ứng với hệ thống mail - Phải có DMARC policy (DNS record) Một hệ thống mail chỉ có mỗi mail server (MTA-E.g: postfix) thì khả năng vào sọt rác là rất cao, thậm chí còn bị Gmail reject , không nhận mail. Cài đặt OpenDKIM Xem tại Ubuntu wiki và ArchLinux wiki chú ý: khi dùng với postfix, mặc dù đã config cho postfix đọc từ UNIX socket trong /var/run/opendkim nhưng sẽ báo ...

Giới thiệu nhanh về MIME

MIME là một từ khoá bạn sẽ nghe tới không ít lần nếu đã sử dụng các email client (MUA) trên desktop. MIME là gì? Viết tắt của cụm từ "Multipurpose Internet Mail Extensions" được mô tả trong RFC 1524 và các RFC khác: RFC 2045 , RFC 2046 , RFC 2047 , and RFC 2231 Nói một cách đơn giản, lúc mới ra đời, giao thức gửi mail chỉ hỗ trợ gửi plaintext, MIME là phần mở rộng cho phép email có thể gửi/nhận các file có định dạng khác (HTML, video, nhạc, ...) Python: xem https://docs.python.org/2/library/email.html Sử dụng MIME Trên UNIX-based OS, các file sau được cung cấp (hoặc tự tạo nếu không có) để hỗ trợ MIME:

ssmtp: gửi gmail từ command line

Bài viết thực hiện trên: $ lsb_release -r Release:        12.04 Bạn có muốn post status FB qua CLI? Chỉ cần vào tk FB, chọn setting => mobile, lấy cái email private đó. Gửi mail từ CLI đến email vừa lấy được => Xong con ong! Để gửi mail (mặc định là Gmail) từ CLI, có nhiều cách, đơn giản nhất là cài ssmtp $ whatis ssmtp ssmtp (8)            - send a message using smtp # cài ssmtp $ apt-get install ssmtp -y Sau khi cài xong cần cấu hình cho ssmtp ở /etc/ssmtp, cần sửa 2 file revaliases và ssmtp.conf

Email miễn phí với domain của bạn

Google free email cho các domain của người dùng đã ra đi từ ngày 6/12/2012, với sự rối loạn và tiếc thương vô hạn của người dùng Đừng lo, đã có các giải pháp thay thế :D 1.OUTLOOK.com yes, một sản phẩm của M$, nhưng không sao cả, tại thời điểm này bạn có thể tạo miễn phí 50 tài khoản email với 1 domain. Yeah

Lột trần một hệ thống email

Email thì ai cũng dùng. Những từ như : from/ recipients / subject ai cũng biết cả. Nhưng đằng sau là một hệ thống server với đầy thuật ngữ. Hãy vạch trần chúng, đưa ra ánh sáng để không còn gì là mờ mịt! 0 . MUA là gì? Mail User Agent (MUA) là loại chương trình cho phép gửi và nhận email. Chương trình này tương tác trực tiếp với người dùng. Các MUA đóng vai trò là SMTP client khi GỬI mail và là  IMAP/POP3 client khi truy cập + đọc mail. VD: Thunderbird, Outlook, mutt , RoundCube, SquirrelMail ... 1 . SMTP là gì ? IMAP là gì? POP3 là gì? 3 giao thức (protocol) dùng trong gửi và nhận email. Đây đều là các giao thức cho mô hình client-server, tức là sẽ có máy đóng vai trò server, và có máy đóng vai client. SMTP : Simple Mail Transfer Protocol - giao thức truyền mail đơn giản (dùng để gửi mail) POP3 : Post Office Protocol 3 - giao thức truy cập mail từ xa. Trong giao thức này, MUA với vai trò POP3 client, download các email về đĩa cứng máy tính cá nhân và xóa các  e...

Popular posts from this blog

Tài liệu và hướng dẫn học Python

Để tiết kiệm thời gian, tốt nhất là đi học PyMI Updated: 130617 Sau đây là các tài liệu khuyên dùng: Vì nhiều lý do, nên học python2.7 tại thời điểm hiện tại (giờ là tháng 6/2013 - muốn biết tại sao thì tự tìm hiểu) python 3.5+ (giờ là tháng 2/2017) Chuẩn bị: 1. biết bật tắt máy 2. biết cài python 3. tập gõ 10 ngón - gõ 2 ngón hay 1 ngón cũng không sao, nhưng 10 ngón là cách dễ nhất để gõ nhanh nhất. Tài liệu - Nên dùng tài liệu tại trang chủ của Python làm chính, tham khảo thêm các tài liệu khác tại http://www.familug.org/2016/12/free-ebook.html Căn bản, mới học 1.1 Python PyMI.vn https://pymi.vn/tutorial/ 1.2. Python offical tutorial kết hợp làm bài tập trên HackerRank  (đề bài bằng tiếng Anh, nhưng Google translate 1 lúc cũng ra vì có nhiều ví dụ mẫu đi kèm). Học viên của Pymi.vn có rất nhiều học viên đã tự học với Learn Python the hard way nhưng chưa thấy ai thành công cả. Hai link dưới nên đọc sau khi đã nắm được những phần cơ bản của ngôn ngữ pytho...

The PyMiers

New FAMILUG